Contactores, controladores, sistemas DCS, PLC, HMI, motores, controladores de motores, variadores de velocidad, convertidores, motores de arranque, servos y unidades, steppers y duros, unidades lineales, interruptores, pulsadores, luces indicadoras, potenciómetros, los dispositivos de E/S , relés, secuenciadores, sistemas de reconocimiento y dispositivos de proximidad.
por
#369362
Hola,
Hay alguien que podría ayudarme en el siguiente problemilla? Estoy simulando unos diagramas de bode de unos controladores resonantes y me acaba saliendo un pico inesperado en magnitud y fase alrededor de la frecuencia de resonancia que no debería estar. Sin este pico, el diagrama es el correcto y esperado ¿A qué error puede deberse este pico? Adjunto el Bode y este es mi código:

Ub=400/sqrt(3);
Ib=3.3;%
w_b=2*pi*50;
Zbase=(Ub)^2/(sqrt(3)*Ub*Ib);
Lbase=Zbase/w_b;
Td=0.00015;
Rf=0.1;
Lf=0.0018;
R=Rf/Zbase;
L=Lf/Lbase;
w=2*pi*50;
kp_1=2*pi*1000*Lf;
ki_1=(Rf/Lf)*kp_1;
s=tf('s');
G_pwm=(1-(Td/2)*s)/(1+(Td/2)*s);
G_i_1=kp_1+ki_1*s/(s^2+w^2);
sys_1_vd=(G_i_1*G_pwm)^2/((L*s+R+G_i_1*G_pwm)*(G_i_1*G_pwm+L*s+R-(1-G_i_1)*G_pwm));
bode(sys_1_vd,'r');
grid on;
xlim([80 1300])
Regístrese y/o inicie sesión para ver archivos adjuntos.
Palabras clave
Temas similares

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados

Permisos de mensaje

No puede abrir nuevos temas en este Foro
No puede responder a temas en este Foro
No puede editar sus mensajes en este Foro
No puede borrar sus mensajes en este Foro
No puede enviar adjuntos en este Foro